Offline due to game update

Resolved
Major outage
Started 7 months ago Lasted about 20 hours

Affected

Game Cheats
League of Legends
Updates
  • Resolved
    Resolved

    Elocarry has now updated this game cheat. Please re-download from your Elopanel.

  • Identified
    Identified

    We are updating to patch 13.19. Please standby for an update.