Server upgrade

Resolved
Partial outage
Started 7 months ago Lasted 1 day

Affected

Website
Elocarry Website
Updates
  • Resolved
    Resolved

    The website is now back online. If you notice anything unusual, please contact staff immediately. Thank you!

  • Monitoring
    Monitoring

    Back to migrating to our new server! Standby for an update.
    **ETA: **26/09/2023 - Evening(BST)

  • Resolved
    Resolved

    We will be continuing the upgrade tomorrow at 12:00 BST

  • Identified
    Identified

    We are upgrading our server to handle our new features, including new game cheats and loader.
    You will not be able to purchase or download Elocarry during this time. However, you will be able to use the cheat still.