Offline due to game update

Resolved
Major outage
Started 8 months ago Lasted 3 days

Affected

Game Cheats
League of Legends
Updates
  • Resolved
    Resolved

    Elocarry has now updated this game cheat. Please re-download from your Elopanel.

  • Monitoring
    Monitoring

    We will be back online today at 23:30 BST. Thank you for your patience.

  • Identified
    Identified

    13.17 - The recent game update has affected this game cheat from being online. Please standby for an update.