ID Server may be down

Resolved
Operational
Started 9 months ago Lasted about 11 hours

Affected

Website
Identification Server (Third Party)
Updates
  • Resolved
    Resolved

    The company that we use for ID authentication is now back online.

  • Investigating
    Investigating

    Our ID system is currently not working as intended. Please standby for an update.
    If you purchased the ID verification fee, please make a ticket and you will be added to the list of those who are affected by this incident.

    https://elocarry.net/forum/support/