Offline due to game update

Resolved
Major outage
Started about 1 year ago Lasted about 7 hours

Affected

Game Cheats
League of Legends
Updates
  • Resolved
    Resolved

    Elocarry has now updated this game cheat. Please re-download from your Elopanel.

  • Identified
    Identified

    The recent game update has affected this game cheat from being online. Please standby for an update. 13.4 will be live soon!