Offline due to game update

Started
February 14, 2023 at 7:58 PM
Status
Monitoring

Impact

Major outage
Affected
Game Cheats
Apex Legends Cheat
  • Monitoring
    February 24, 2023 at 11:01 PM

    Statement regarding Apex Legends cheat here.

  • Monitoring
    February 14, 2023 at 7:58 PM

    The recent game update has affected this game cheat from being online. Please standby for an update.