Update 13.3 - Offline due to game update

Resolved
Major outage
Started about 1 year ago Lasted 1 day

Affected

Game Cheats
League of Legends
Updates
  • Resolved
    Resolved

    Updated to 13.3. Enjoy!

  • Monitoring
    Update

    We are making sure that Riot's update fixed the problem. I am confident we should be back online today.

  • Monitoring
    Monitoring

    We have successfully updated to 13.3 however the Orbwalker is currently broken due to the game itself. We are analysing the situation on an hourly basis.

  • Identified
    Identified

    The recent game update has affected this game cheat from being online. Please standby for an update.