League of legends - offline

Resolved
Major outage
Started 9 days ago Lasted 1 day

Affected

Game Cheats
League of Legends
Updates
  • Resolved
    Resolved

    Great news, Legends! Our League of Legends cheats are back online. Dive back into the action and let the games begin. Thanks for sticking with us! Please re-download from your dashboard area.

  • Investigating
    Investigating

    The latest game update has temporarily disrupted the availability of this game cheat. Please stay tuned for an impending update.

    Remember to join our Discord server and continue checking this page for updates.