Resolved
Offline due to game update

Started
February 07, 2024 at 12:49 PM
Status
Resolved after about 22 hours

Impact

Major outage
Affected
Game Cheats
League of Legends
  • Resolved
    Resolved

    Elocarry is now running the most up-to-date game version. To ensure smooth gameplay, kindly proceed to reacquire your client from the dashboard section.

    Remember, it's a good practice to engage in a test run within the practice mode following any updates. Given the sheer variety of over 100 champions, it's not feasible for our team to thoroughly test each one before every update. Should you come across any bugs or issues, we encourage you to report them through our dedicated bug tracking system.

  • Identified
    Identified

    The latest game update has temporarily disrupted the availability of this game cheat. Please stay tuned for an impending update.
    Remember to join our Discord server and continue checking this page for updates.