Resolved
Offline due to game update

Started
September 13, 2023 at 8:23 AM
Status
Resolved after about 9 hours

Impact

Major outage
Affected
Game Cheats
League of Legends Cheat
  • Resolved

    Elocarry has now updated this game cheat. Please re-download from your Elopanel.

  • Identified

    The recent game update has affected this game cheat from being online. Please standby for an update.