Elocarry - Offline due to game update – Incident details

Offline due to game update

Resolved
Major outage
Started over 1 year agoLasted about 4 hours

Affected

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    The recent game update has affected this game cheat from being online. Please standby for an update. 13.12HF will be live soon!