Elocarry - Updated to 13.11HF – Incident details

Updated to 13.11HF

Resolved
Major outage
Started over 1 year agoLasted about 2 hours

Affected

Updates
  • Resolved
    Resolved

    Elocarry has now updated this game cheat. Please re-download from your Elopanel.

  • Investigating
    Investigating

    The recent game update has affected this game cheat from being online. Please standby for an update. 13.11HF will be live soon!